• SeanD
    0
    I'm restoring a non-encrypted bare-metal image backup from S3 into a dynamic Hyper-V Virtual Disk. I'm only restoring the MBR disk. It fails each time I try:

    After 10min (2.7GB of downloaded data), it failed, with a Last Result of:
    Type Plan Name File Size Result Start Time Finish Time Duration Message
    Restore Restore plan on 3/27/2019 6:47:34 AM 2 101977168421 Failed 2019-03-27 06:47:42 2019-03-27 06:57:55 613 Index (zero based) must be greater than or equal to zero and less than the size of the argument list.


    From what I can tell, there was an invalid array index exception in a VB script. Is this a known bug, is there a workaround? I'm using the latest CloudBerry Backup software.
  • Matt
    58
    Just to clarify: are you trying to restore that image by somehow mounting bootable USB on a VM and then trying to recover the data from it or using this method https://help.cloudberrylab.com/cloudberry-backup/restore/restore-an-image-based-backup/step-5-specify-the-restore-destination/restore-to-virtual-disk ?
    The second procedure is the correct one.

    I saw this error only a couple of times, but only during backups, so this is pretty unusual.
  • SeanD
    0
    Thanks for the quick response. My steps are similar to the above doc page. This is a restore of a bare metal image to a Virtual Disk file on a local disk destination (not a mounted USB). I've also tried writing to a NAS with the same result, as well as restoring all disks, not just the MBR drive.

    Here's the callstack I'm seeing in the log. From experience, I'd say you have a string format spec in the code that doesn't match the number of arguments given.


    2019-03-27 11:23:54,160 [PL] [8] ERROR - Error occurred on restore
    System.FormatException
    Index (zero based) must be greater than or equal to zero and less than the size of the argument list.
    at System.Text.StringBuilder.AppendFormatHelper(IFormatProvider provider, String format, ParamsArray args)
    at System.String.FormatHelper(IFormatProvider provider, String format, ParamsArray args)
    at Oz.a(Int32 )
    at Oz.gR(Int32 )
    at aZY.A(Nullable`1 )
    at aZY.Read(Byte[] , Int32 , Int32 )
    at DiscUtils.BuiltStream.Read(Byte[] buffer, Int32 offset, Int32 count)
    at DiscUtils.SnapshotStream.Read(Byte[] buffer, Int32 offset, Int32 count)
    at DiscUtils.SubStream.Read(Byte[] buffer, Int32 offset, Int32 count)
    at DiscUtils.BuiltStream.Read(Byte[] buffer, Int32 offset, Int32 count)
    at DiscUtils.Utilities.ReadFully(Stream stream, Byte[] buffer, Int32 offset, Int32 length)
    at DiscUtils.StreamPump.RunSparse()
    at BbL.gm(DiskImageFileSpecification )
    at Bbk.SX(SparseStream )
    at BbH.A(aAm , aCW , Bbh )
    at OQ.Fu()
    at aCX.Ls()
    at aEp.D()
  • Matt
    58
    Pretty unusual to see these errors on restore. Make sure you're on the latest version, reproduce the problem and send us the diagnostic logs via tools > diagnostic menu. Mention this thread in the issue description please.
  • SeanD
    0
    Ok, I've sent the diagnostic to support. I'm using build 6.0.0.249.
  • Ed Poulton-Gee
    0
    I'm currently seeing this error whilst trying to restore a bare-metal VM from S3

    Running version 6.0.0.249

    Were you able to find a work around?
  • Matt
    58
    This problem will be fixed in version 6.1 which is scheduled for release next week(although delays may happen). If you create a ticket by sending us the logs with reference to this forum thread I might be able to provide an early build.
  • Ed Poulton-Gee
    0
    Hi Matt, thanks for getting back to me. I had raised a ticket previously, ticket ID: ## 227494 ##
    Please let me know if you're able to get an early build. Cheers!
  • Matt
    58
    Yep, found the ticket. Check your inbox, I already sent you the link with the build.
bold
italic
underline
strike
code
quote
ulist
image
url
mention
reveal
youtube
tweet
Add a Comment

Welcome to CloudBerry Lab Forum!

Thank you for visiting! Please take a moment to register so that you can participate in the discussions!