• Sinon
    0
    Hi,

    another problem I have regards connecting to a VPN before the backup to upload files to a distant NAS. The last part works, when I connect manually. But I'd like to automate this process to make use of a scheduled plan.
    Just putting the rasdial cmd in the trigger-flields didn't work. So I created two cmd-files in the CBB directory "connect" and "disconnect" with the simple rasdial command to connect to the VPN or cut the line. When I launch the files manually, they work as intended.
    I then put the paths to the files in the pre- and post-backup actions form. Having done that, the backup fails to start, though, because the pre-backup trigger fails with error 623 (rasdial would spit this out on an unknown VPN-name, but as I said: The scripts work when launched manually).
    So where is the mistake in my plan?
  • David Gugick
    19
    Maybe you need to use the RunAs command to start the VPN under the correct user account in the Pre CMD script. My guess is it's a user rights issue. Could also be that the VPN is setting things up in the background and it's not ready by the time the script kicks off the backup. You could put a delay in the CMD to prevent it from returning immediately.
  • Sinon
    0
    I use runas to run it as the current user with which executing the cmd works manually. But still, no success when triggering it through CBB. The delay doesn't help, neither. :(
  • David Gugick
    19
    What account are you running CloudBerry Backup under?
  • Sinon
    0
    Standard System i guess. Never changed that. But a good hint, I'll experiment with that.

    Edit: Jep, that did the trick. Ran it under my user account and now the scripts work as intended. Thanks a lot!
  • David Gugick
    19
    Great! Glad to hear this is resolved.
bold
italic
underline
strike
code
quote
ulist
image
url
mention
reveal
youtube
tweet
Add a Comment

Welcome to CloudBerry Lab Forum!

Thank you for visiting! Please take a moment to register so that you can participate in the discussions!